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OVERVIEW

About

The Glyph Software Mattepainting Toolkit (gs_mptk) is a plugin suite for Autodesk Maya that helps artists 
build 2.5D and 3D environments from multiple camera projections.  All functionality is controlled through a 
custom user interface that manages the shading networks, and a hardware shader specifically designed for 
modeling from camera projections provides feedback in the viewport.

Why use gs_mptk?

When texturing geometry in Maya, it is often preferable to use camera projections over UV placements, but 
the limited toolset Maya provides is unintuitive and labor intensive.  Combining multiple projections is 
cumbersome and requires extra effort to paint holdout mattes to define explicit boundaries.  Projection 
smearing, doubling on backfaces, and loss of resolution over large surface areas are common problems 
that take time to patch.

gs_mptk removes the technical burdens of setting up projections in Maya and allows artists to focus on the 
composition of the imagery.  The advanced blending features of the toolkit are designed to target the 
challenges of integrating multiple projections, and reduce the number of mattes needed to isolate geometry.

gs_mptk was built for mattepainters and texture artists, not programmers.  A lot of consideration went into 
designing a system that functions in an intuitive way, implements time-saving features, and minimizes 
repetition.  

What's included in gs_mptk?

• gs_mptk consists of a UI that manages connections to custom Mental Ray and V-Ray shaders.  It is 
lightweight and easily installed on multiple systems and render farms.

• gs_projCamMix is the dynamically-loaded mental ray shader that forms the foundation of the Mattepainting 
Toolkit and allows multiple projections to be blended based on a number of user-defined parameters.

• gs_occlusionMatteVRay and gs_projCamMixVRay together perform the same function for V-Ray as the 

• gs_projCamMix mental ray shader.

• gs_viewportProj is the maya plugin that visualizes projections in the viewport using OpenGL.

• gs_mptk_UI.mel is the MEL script that loads the interface to manage connections into     gs_projCamMix 
and provides additional features.

• gs_const is an optional constant shader that is connected at the end of the shading network by 
gs_mptk_UI.

What does it do?

Simply, it blends multiple camera projections, in the order they are assigned, based on the blending 
parameters given to each projection.  gs_mptk uses occlusion masking to determine which areas of a model 
are unseen by a projection camera, and patches these areas with other projections, based on their order of 
priority.  



Aside from the rendering functions, gs_mptk makes the process of setting up projections, and then 
managing them, as straightforward as possible through a custom user interface.

gs_mptk also includes features to assist modeling from projected images, including a Structure From Motion 
data importer to reconstruct camera positions from photographs, and an OpenGL shader that allows artists 
to get immediate feedback from their projections as they model.

Requirements
Maya 2012 Hotfix 4 or Maya 2013
V-Ray renderer to use the V-Ray gs_mptk shaders
Window, OSX, or Linux

A note about the V-Ray shaders

For Maya 2012, you will need at least stable version 2.10.01 from 4/9/2012
Maya 2013 does not have a version requirement

A note about the demo version

The gs_mptk demo has the following limitations:

• The gs_viewport_proj has a watermark in the viewport.
• Rendering with gs_projCamMix will display a red noise pattern over half the rendered image.

FEATURES

What's new in this release?

Features

• V-Ray integration
• Photosynth integration
• Animated sequences are now supported for projections.
• Multiple projection layering in the viewport.

Fixes

• gs_mptk_UI assumes images with alpha channels that are added to the projection list should set shader 
transparency by default.
• gs_mptk_UI will not crash when adding projection cameras that have constraints.
• Multiple projection groups now composite properly.
• Geometry can now self-occlude in masking operations.
• Camera import from SFM data now does a proper matrix decomposition for all camera orientations.

Deprecations and Limitations

• miLabel is not supported in masking operations.

INSTALLATION

The following paths are indicated as default Maya install locations.  Alternative setups may require different 
install locations.  Administrative privileges may be required to install, depending on your platform 
configuration.



OSX 

Notes: 
* $USER in the paths below is the username on your machine. 

copy contents of icons folder to: 
/Users/Shared/Autodesk/maya/icons
 
copy contents of scripts folder to: 
/Users/$USER/Library/Preferences/Autodesk/maya/2013/scripts

copy contents of plug-ins folder to: 
/Users/Shared/Autodesk/maya/plug-ins 

copy contents of mentalray/include to: 
/Applications/Autodesk/maya2013/mentalray/shaders/include 

copy contents of mentalray/lib to: 
/Applications/Autodesk/maya2013/mentalray/shaders

copy contents of vray/shaders to: 
/Applications/Autodesk/maya2013/vray/shaders 

copy contents of vray/vrayplugins to: 
/Applications/Autodesk/maya2013/vray/vrayplugins

WINDOWS

Notes: 
• $USER in the paths below is the username on your machine.  
• The paths below are given for Windows 7.  Other versions of Windows may have different paths.

copy contents of icons folder to: 
C:\Users\$USER\Documents\maya\2013-x64\prefs\icons 

copy contents of scripts folder to: 
C:\Users\$USER\Documents\maya\2013-x64\prefs\scripts 

copy contents of plug-ins folder to: 
C:\Program Files\Autodesk\Maya2013\bin\plug-ins 

copy contents of mentalray\include to: 
C:\Program Files\Autodesk\Maya2013\mentalray\shaders\include 

copy contents of mentalray\lib to: 
C:\Program Files\Autodesk\Maya2013\mentalray\shaders

copy contents of vray\shaders to: 
C:\Program Files\Autodesk\Maya2013\vray\shaders 

copy contents of vray\vrayplugins to: 
C:\Program Files\Autodesk\Maya2013\vray\vrayplugins

LINUX



Notes: 
* $USER in the paths below is the username on your machine.  

copy contents of icons folder to: 
/home/$USER/maya/2013/prefs/icons 

copy contents of the scripts folder to: 
/home/$USER/maya/2013/prefs/scripts 

copy contents of plug-ins folder to: 
/usr/autodesk/maya2013/bin/plug-ins/ 

copy contents of mentalray/include to: 
/usr/autodesk/maya2013/mentalray/shaders/include 

copy contents of mentalray/lib to: 
/usr/autodesk/maya2013/mentalray/shaders/
 
LICENSING

Two license files can be found in the licensing folder: 
gs_mptk_floating_license.lic and 
gs_mptk_local_license.lic 

NODE-LOCKED LICENSES 

If you purchased a node-locked license, you only need to update gs_mptk_local_license.lic 

1) Open gs_mptk_local_license in a text editor. 
2) Replace the license key found in gs_mptk_local_license with your license.  Make sure to leave the first 
line as "localhost" 
3) Save the changes, and copy gs_mptk_local_license.lic to: 
/Applications/Autodesk/maya2013/Maya.app/Contents/Resources 

FLOATING LICENSES 

If you purchased a floating license, you need to update both gs_mptk_local_license.lic and 
gs_mptk_floating_license.lic 

1) Open gs_mptk_local_license in a text editor. 
2) Replace the license key found in gs_mptk_local_license with your local license key. 
3) Replace the first line, "localhost" with the server location for the floating license file, e.g.: 
/Volumes/My HD/licenses/gs_mptk_floating_license.lic for OSX
The path should follow the syntax given by the Finder (use Get Info on a folder for specific location syntax).
or
\\192.168.0.155\my_license_location\gs_mptk_floating_license.lic for Windows
Make sure to include the filename gs_mptk_floating_license.lic at the end of the path.
4) Save the changes, and copy gs_mptk_local_license.lic to: 
/Applications/Autodesk/maya2013/Maya.app/Contents/Resources for OSX
or
C:\Program Files\Autodesk\Maya2013\resources for Windows
5) Open gs_mptk_floating_license.lic in a text editor. 
6) Replace the contents of the first line with your floating license key. 
7) Save the changes, and copy gs_mptk_floating_license.lic to the location you specified in 
gs_mptk_local_license.lic 



8) Make sure the floating license location is accessible from the machine you're running gs_mptk, or 
gs_mptk will revert to demo mode. 
9) Make sure that both of the license files have read/write access, or gs_mptk will revert to demo mode.

TROUBLESHOOTING LICENSES

When you load the gs_mptk shaders, they will print info about the license status, either into the Output 
Window on Windows, or the shell you launched Maya from on OSX.  If you run into a licensing error, 
gs_mptk will run in demo mode, and you should refer to the status printouts for more information.  For node-
locked licenses, you can check the status of your MAC address by typing ipconfig (windows) or ifconfig 
(OSX and linux) in a shell or command prompt.  

For floating licenses, make sure the location of the license server is accessible from your local machine. 
Try to connect to the location directly and map the network drive if the license error printouts indicates 
issues connecting to the license server.

You can test whether the license error has been corrected by simply closing the scene file that is using 
gs_mptk, and re-opening it; you do not need to exit Maya altogether.

gs_mptk will run in demo mode when a license error has occurred, or if the number of available licenses are 
all in use.

To run gs_mptk:

1) launch Maya 2013
2) load both gs_projCamMix mental ray shader and gs_viewportProj maya plugin: 
Window>Settings/Preferences>Plug-in Manager>gs_viewportProj 
Window>Rendering Editors>mental ray>Shader Manager>gs_projCamMix 
3) load the vray shaders: 
Window>Settings/Preferences>Plug-in Manager>gs_occlusionMatteVRay.mll 
Window>Settings/Preferences>Plug-in Manager>gs_projCamMixVray.mll 
4) source gs_mptk_UI.mel from the script editor.

THE UI

The UI is loaded by sourcing gs_mptk_UI.mel through the script editor.  Alternatively, you can add gs_mptk 
to a shelf and source it from there with the “source” command, e.g.: 
source "/Users/Shared/Autodesk/maya/2013/scripts/gs_mptk_UI.mel";
The included hypershade icons can be used as shelf icons as well.

Make sure the gs_projCamMix shader and is loaded in Window>Rendering Editors>mental ray>Shader 
Manager, or the script will return the error:
Unknown object type: gs_projCamMix
Make sure also the gs_viewportProj plug-in is loaded in Window>Settings/Preferences/Plug-in Manager
along with gs_occlusionMatteVRay and gs_projCamMixVRay if you use V-Ray to render.

When the UI loads, all gs_projCamMix nodes existing in the current scene are loaded into a tabbed layout 
as projection groups.  The projections and matte connected to each projection group are also displayed, 
along with their attributes and assigned object list.

Menus
File

Import... - will import SFM data coming from bundler, photosynth, etc., with the .out extension

New Shader - will create a new gs_projCamMix node.



RefreshUI - will refresh the UI to update any changes not made within it.

Create coverage map - will render a coverage map from the current viewport 
perspective that shows which areas of the selected geometry are visible to the selected 
camera over the time range specified in the timeline.  Select a camera and a any 
number of objects before invoking this command.  The resulting render respect the 
settings of the Render Globals.

Close - close the UI.

Options
    

VRay Rendering – when checked, vray shading networks will be created for all projection 
groups.  The networks will be updated whenever a change is made to the projection 
attributes.

File Filtering – will set all files associated witht the projection group to the selected 
filtering method.

Viewport Lin to sRGB – for projections in linear color space, this toggle will enable 
gamma conversion to sRGB color space.

Viewport Layering – will show up to 7 layered projections in the Projection List within the 
viewport.

    Debug Mode - enable to print messages to the Script Editor for any modifications         
made to the projections through the UI.

Debug Step - enable to pause after each command is invoked during modifications         
made to the projections through the UI.

Help
    About... - display the version of gs_mptk

Tabbed Layout

The tabbed layout has three buttons for creating, removing, and selecting projection groups.  A projection 
group is comprised of a gs_projCamMix node and all of its incoming connections.  Each gs_projCamMix 
node in the scene is represented in the tabbed layout.

    +    Add a new projection group.  This will create a gs_projCamMix node with a basic setup, 
including a file projection for the color and ramp for the mask.

   -    Remove a projection group.  The projection group of the currently selected tab will be 
removed.  All nodes with connections to the group, except cameras, will be deleted.

    ^    Select the projection group.  This will select the gs_projCamMix node of the currently 
selected tab.

Projection List

The projection list represents all of the projections connected to the color inputs of the gs_projCamMix 
node.  The images projected in this list will constitute the RGB of the render.  The list is in a top-down 
priority, so that projections higher in the list have greater priority at render time.  In other words, projections 
are layered on top of each other from the bottom of the list to the top.



Projections are made current by the > button.  When a projection is made current, it is highlighted light gray, 
and all of its attributes, as well as its matte list, are displayed in the middle pane of the UI.

    +    Add a new projection.  A new file projection is added to the projection group, with 
priority over the current projection.

    -    Remove the current projection.  The current projection is deleted.
    ^    Select the projection.  The current projection is deleted.

Each projection in the list has a thumbnail preview on the left, a name that corresponds to the projection 
node itself (editable), the path to the image on disk (editable), a button labelled “...” to browse for images on 
disk, and a button labelled “>” to make the projection current in the list and display its attributes.

In Windows and OSX, the projection image can be edited by clicking on the thumbnail preview.  This will 
launch the image editor specified by the user in Window>Settings/Preferences>Preferences>Applications. 
This feature is not available by default in Linux.

When a file texture with an alpha channel is added to the projection with the “...” browse button, its alpha 
channel is detected and the user has the option to add the alpha channel to the Additional Mattes list.  Note 
that a file’s alpha channel is not detected when editing the path field directly.

Projections in the list can be reordered by middle-mouse dragging them to the desired position.  Projections 
can be swapped by shift-middle-mouse dragging from one index to another.  Note that the drag-drop area of 
the projections does not include the field areas.

When a projection is added to the list, a gs_viewportProj hardware shader is added to visualize the 
projection in the viewport.  Similarly, when the “>” button is used to select a projection, it will be displayed in 
the viewport, overriding the previous viewport projection.

When Viewport Layering is enabled in the Options menu, up to 7 projections in the Projection List will be 
layered in the viewport.  The current active projection determines the top projection visible in the viewport, 
the the 6 projections below it in the list will be layered underneath.

Projection Attributes

    Camera
        The + button will assign the currently selected camera to the current projection.  The 

camera name will be assigned to the button on the right, which will in turn select the 
camera when it is pressed.

    Color Offset
        This color picker will add color to the current projection image.  It is useful to help 

balance projections that have a slightly different value from others in the list, or to make 
radical changes that expose the projection’s contribution in a render.

    Pass Through
        This check box will bypass the current projection at render time, effectively removing its 

contribution to the projection group.

Matte Attributes

    Distance Threshold
        When this field is set > 0, the current projection will only project onto geometry that             

falls at a cm distance less than the value set.  This value is always read as cm, and         
does not convert to other working units set in the preferences.

    Use Shadow Occlusion



        When checked, geometry not seen by the projection camera are masked at render             
time.  These masked areas will be filled by the next projection in the list if it is visible         
to the camera of that projection.  In this way, the gs_projCamMix shader works from         
the top of the projection list down to the bottom, filling in masked areas with the next         
projection that is able to “see” them.  This feature is called “shadow occlusion”             
because the projection camera acts like a light to determine what areas of the             
geometry are shadowed.  In order for this feature to work, raytracing must be             
enabled in the Render Globals.  The following attributes are enabled with shadow             
occlusion:

        Dilate
            This attribute will expand the shadow area.  Since it is often difficult to have a 

perfect correlation between the edges of a projected texture and geometry edges, the 
dilate attribute can conceal edge bleeding by expanding the shadow mask.

        Samples
            This attribute sets the number of samples per pixel for the shadow mask.  It                 

should be enabled only when Soft Edge is > 0.

       Soft Edge
            This attribute creates adds feathering to the dilated shadow area.  It is bound to a 0-1 

range, where 1 is maximum feathering.

        Power
            This attribute adds density to the Soft Edge.  It is often preferable to                     

increase the Power when using Soft Edge to ensure that the dilated area produces a 
solid matte at the geometry’s shadow boundary.

        You can think of the Shadow Occlusion attributes like this:
        

The geometry’s shadow boundary is the hard edge between the visible and invisible areas seen 
from the projection camera.  When you dilate this shadow area, you are masking areas that are seen 
by the projection camera, and allowing other projections lower in the projection list to try to fill this 
area.  By enabling Soft Edge, you are adding transparency into this dilated area, but not the hard 
shadow area that is not seen by the projection camera.  With transparency in the mask, a 
percentage of the current projection’s contribution will be mixed with the projections lower in the list 
that are able to see this dilated area.  The Power attribute weights the percentage blending in the 
favor of projections lower in the list. Increasing the Samples will produce a smoother (less noisy) 
blend at the expense of render time.

    Use Facing Ratio
        This attribute will prevent the current projection from projecting onto geometry             

backfaces when Angle Threshold = 90.  If Angle Threshold < 90, areas of the             
geometry visible to the projection will be masked as well.  Facing Ratio produces a 
mask with a value of either 0 or 1, depending on the Angle Threshold.

        Angle Threshold
            The Angle Threshold extends the backface culling to include front faces,                 

based on the angle between the camera view vector and the geometry                 
normal.  It is specified in degrees, from 0 to 90.

        It is often advantageous to use backface culling with projections, and this is achieved by 
enabling Facing Ratio and setting the Angle Threshold to 90.  Sometimes, however, it is also 
necessary to mask geometry that is visible to the camera at a grazing angle so that 
projected textures do not smear across the geometry.  This is achieved by setting the 
Angle Threshold < 90.



    Label Exclude
        This feature has been deprecated.

Premult
On by default; gs_mptk assumes users will want to multiply images in the Projection List by 
the mattes in the Additional Mattes list.  This is useful for photographs, for example, where 
the RGB of the image does not contain a matte.  For images in the Projection List that are 
already premultiplied by a holdout matte in the RGB channels, you will want to DISABLE 
Premult—otherwise your mattes will be double multiplied, and you will see darkened edges in 
your resulting render.

Additional Mattes

    The Additional Mattes list is organized the same way as the Projection List, except that 
it does not have drag/drop functionality.  All mattes in the list are multiplied together 
before they are connected to the gs_projCamMix node, so there is no need for order of 
priority like the Projection List.  

When a matte file is loaded with the “...” browse button, the user has the option of choosing     
which channel in the image will be used for the matte.  In this way, it is possible to have up         
to 4 separate mattes (R, G, B, and A) in each file.  All mattes in the list project from the         
same camera as the current projection.

The Additional Mattes list applies only to the current projection, and is included as a way for 
users to generate custom mattes that mask areas not defined by the Matte Attributes.

    
+    Add a matte projection.
– Remove the current matte from the list.

Object List

This list displays the names of all objects (geometry) associated with the gs_projCamMix node.  
Since the gs_projCamMix node is identified as a Mental Ray texture, it does not have a shading 
engine and does not make direct shading assignments.  Instead, an output connection is made 
between the gs_projCamMix node and another shader that is assigned to the geometry.  In this way, 
the gs_projCamMix node can easily fit into a pipeline that has custom shaders.

    
It is necessary to add geometry to the Object List in order for them to render.

    
The Object List allows for multiple selections by either click-dragging, shift-clicking, or, for         
non-contiguous selections, ctrl-clicking (cmd-clicking on OSX).

    If shader assignments are made to geometry outside of the UI, it is necessary to refresh         
the UI in order to see these changes reflected in the Object List.

    +    To add an object to the Object List, gs_projCamMix must have at least one                 
outgoing connection to a shader connected to a shading engine.  If no outgoing 
connections are found, a default gs_const shader is created and connected 
to .outColor of the current gs_projCamMix node.

        This button can also change shader assignments to objects already in the 
Object List.  For example, if there are multiple outgoing connections from 
gs_projCamMix to different shaders, any object in the list can by 
assigned to a different shader because the list of connected shaders is 
invoked every time the + button is pressed.



        Note that only shaders with incoming connections from gs_projCamMix and 
outgoing connections to shading engines are detected by the + button.  Shaders 
are connected to shading engines by default when they are created through the 
Hypershade, so this is not usually an issue.

    -    This button will remove the shader assignment from the geometry selected in 
the list.

    ^    This button will select the geometry selected in the list.

USAGE AND TROUBLESHOOTING

The best way to get familiar with the Mattepainting Toolkit workflow is to watch the online videos at 
www.glyphfx.com/mptk.html  The following is a list of technical considerations for rendering.  Check the 
website for the most up-to-date information on usage, issues, and bug reporting.

When enabling VRay Rendering in the Options of gs_mptk_UI, you may receive an error that a connection 
can not be made to gs_mptkSGxx.vraySpecificSurfaceShader.  This can happen the first time a shading 
network is created.  To fix the problem, simply un-check VRay Rendering from the Options menu, and then 
re-enable it.

gs_mptk will perform an Over operation when compositing images together.  Take note of the Premult 
switch described above to avoid double multiplication of mattes.

Transparency operations are calculated with raytracing.  Make sure raytracing is enabled in your renderer 
when calculating transparency.

When compositing multiple layers of transparency, make sure to have your raytracing limits set high enough 
to avoid early termination of the ray.  Refer to Mental Ray and V-Ray documentation for more information on 
raytracing limits.

When using shadow occlusion with the Dilate option, be aware that render times can increase significantly. 
This is due to the increase in rays probing for occluding geometry, and is directly related to an increase in 
Dilate and Samples values.  Keep these attributes as low as possible.  Mental Ray and V-Ray use different 
algorithms for sampling, so there will be a visual difference in the mattes generated with this feature of the 
toolkit.

If you notice black edges in the V-Ray shadow occlusion of transparent images, disable Filter Maps under 
Render Settings>VRay tab>Global Options>Materials>Filter Maps

You do not have to use gs_const (Mental Ray) or the default Maya Surface Shader (V-Ray) that is added at 
the end of the shading network by default.  To use other shading models, connect the relevant outputs of 
gs_projCamMix to your material shader of choice.  The advantage of the default materials created by 
gs_mptk_UI is that they are fast and reliable.  They do not, however, take lighting calculations into 
consideration.  To get lighting evaluation, you will have to connect the outputs of gs_projCamMix to your 
shader of choice.  Note that when using custom shaders, gs_mptk_UI will have no knowledge of these 
connections, and may therefore become unreliable.  It is therefore suggested that changes to the shading 
network should only be performed as a last step before rendering.

When using custom shaders in place of gs_const (Mental Ray), make sure to connect the outMatte and/or 
outTransparency plugs to your custom shader, or Mental Ray may not evaluate transparency operations 
correctly.

At the time of writing, V-Ray does not evaluate Maya camera projection types and film gates when 
rendering.  As a result, V-Ray requires that image aspect ratio match the camera resolution ratio.  This is 



different than Mental Ray, which will squash or stretch an image to fit the camera film gate, and can project 
images independent of the render resolution ratio.  gs_mptk defaults to using native Maya projection 
capabilities since they are more versatile when mixing projections of different resolutions and ratios.  When 
rendering in V-Ray, however, the projection type for all projections must be set to Fit Type = Match Camera 
Resolution and Fit Fill = Horizontal.  You can use the included gs_vray_pfit.mel script to convert all 
projections in the scene for V-Ray compatibility.  This should be done whenever a new projection is added 
to the Projection List, or a new gs_projCamMix shader is created.  Note that this script is a one-way 
operation, and while Mental Ray renders will respect the changes, you will need to manually adjust the 
Camera Projection Attributes on the projection node to project with different ratios in Mental Ray.

To help V-Ray shadow Occlusion artifacts, select the mesh producing the artifacts, as well as the occluding 
object, and in the Attribute Editor, add Attributes>VRay>Subdivision and Displacement Quality, as well as 
Subdivision.  Then lower Edge Length.

V-Ray transparency tracing can be slow to render.  One option to increase render speed is to set the 
transparency cutoff to 1 in Render Settings>VRay>Global Options

In some cases, alpha channels are not detected by gs_mptk_UI.  This is related to the Maya function 
fileHasAlpha returning 0.  If an alpha channel of your projection is not detected by default, add it to the 
Additional Mattes list manually.

END


